Fatal error: Call to undefined function is_checkout() in Motors theme

WooCommerce 3.9 now requires WordPress 5.0 and PHP 7.0 or later to run.

WooCommerce 3.9 now requires WordPress 5.0 and PHP 7.0 or later to run. Here you can see more about Woocommerce requirements - https://docs.woocommerce.com/document/update-php-wordpress/.

Why update PHP

PHP is the coding language that WordPress and WooCommerce run on and is set on a server level by your hosting company that you can typically control within your hosting panel.

Performance

The latest version of PHP has been developed to be more performant and efficient than former versions of PHP, so updating can make your WooCommerce store up to 3-4 times faster.

Security

PHP is the world’s most popular web programming language and, similar to WordPress, is a target for hackers. Running the latest version of PHP ensures that loopholes in older versions cannot be exploited because the team is consistently making improvements.

How to update PHP

  1. Make a backup before performing an update in case anything unexpected happens.

  2. Follow instructions at Update PHP from the WordPress.org website - https://wordpress.org/support/update-php/. It gives details and a template you can copy/paste in requesting help from your hosting provider to upgrade your version of PHP.