System Requirements

Here are the system requirements you need in order to use the eRoom and avoid any technical issues. If you are not sure whether your server supports this, contact your host.

  • WordPress 5.0 or Greater It is recommended to use WordPress 5.5 or greater with eRoom Plugin

  • PHP 7.2.5 or Greater

Note: If your site is hosted on a server with an older PHP, you may experience issues. We recommend you contact your hosting provider to upgrade to the latest version of PHP.

  • Guzzle 6.3.3 or Greater It is recommended to use Guzzle 6.3.3 with eRoom Plugin. For easily sending HTTP requests and trivial to integrate with web services, you need to use Guzzle PHP HTTP client.‚Äč

The following requirements should be set to use GuzzleHttp PHP client web service before using eRoom plugin:

  1. To use the PHP stream handler, allow_url_fopen must be enabled in your system's php.ini.

  2. To use the cURL handler, you must have a recent version of cURL >= 7.19.4 compiled with OpenSSL and zlib.

  • MySQL 5.6 or Greater

  • WP Memory Limit WP Memory limit of 128 MB or greater (256 MB or higher is preferred).